Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

ntpq: read: Connection refused

I deployed OPNFV Brahmaputra 1.0. After finishing deployment, I checked the status of ntp on one controller node. Ntp could connect to server. The status of ntp service on ntp client and ntp server were normal. Then I restarted ntp service on client. It conneted a while but disconnected quickly. The ntp server is on jumpserver(ip: 10.20.0.1). The log is below:

root@node-41:~# ntpq -p
ntpq: read: Connection refused
root@node-41:~# service ntp status
* NTP server is running
root@node-41:~# service ntp restart
* Stopping NTP server ntpd                   [ OK ]   
* Starting NTP server ntpd                    [ OK ]
root@node-41:~# ntpq -p
 remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
*10.20.0.1       LOCAL(0)         9 u    1    8    1    0.130    2.362   0.004
root@node-41:~# ntpq -p
 remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
*10.20.0.1       LOCAL(0)         9 u    5    8    3    0.130    2.362   0.257
root@node-41:~# ntpq -p
ntpq: read: Connection refused

Here is content of ntp.conf.

root@node-41:/etc# cat ntp.conf
# ntp.conf: Managed by puppet.
#
# Enable next tinker options:
# panic - keep ntpd from panicking in the event of a large clock skew
# when a VM guest is suspended and resumed;
# stepout - allow ntpd change offset faster
tinker panic 0 stepout 5

disable monitor

# Permit time synchronization with our time source, but do not
# permit the source to query or modify the service on this system.
restrict -4 default kod nomodify notrap nopeer noquery
restrict -6 default kod nomodify notrap nopeer noquery
restrict 127.0.0.1
restrict ::1

# Set up servers for ntpd with next options:
# server - IP address or DNS name of upstream NTP server
# iburst - allow send sync packages faster if upstream unavailable
# prefer - select preferrable server
# minpoll - set minimal update frequency
# maxpoll - set maximal update frequency
server 10.20.0.1 iburst minpoll 3

# Driftfile.
driftfile /var/lib/ntp/drift

Any ideas why this is happening?

ntpq: read: Connection refused

I deployed OPNFV Brahmaputra 1.0. After finishing deployment, I checked the status of ntp on one controller node. Ntp could not connect to server. The status of ntp service on ntp client and ntp server were normal. Then I restarted ntp service on client. It conneted a while but disconnected quickly. The ntp server is on jumpserver(ip: 10.20.0.1). The log is below:

root@node-41:~# ntpq -p
ntpq: read: Connection refused
root@node-41:~# service ntp status
* NTP server is running
root@node-41:~# service ntp restart
* Stopping NTP server ntpd                   [ OK ]   
* Starting NTP server ntpd                    [ OK ]
root@node-41:~# ntpq -p
 remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
*10.20.0.1       LOCAL(0)         9 u    1    8    1    0.130    2.362   0.004
root@node-41:~# ntpq -p
 remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
*10.20.0.1       LOCAL(0)         9 u    5    8    3    0.130    2.362   0.257
root@node-41:~# ntpq -p
ntpq: read: Connection refused

Here is content of ntp.conf.

root@node-41:/etc# cat ntp.conf
# ntp.conf: Managed by puppet.
#
# Enable next tinker options:
# panic - keep ntpd from panicking in the event of a large clock skew
# when a VM guest is suspended and resumed;
# stepout - allow ntpd change offset faster
tinker panic 0 stepout 5

disable monitor

# Permit time synchronization with our time source, but do not
# permit the source to query or modify the service on this system.
restrict -4 default kod nomodify notrap nopeer noquery
restrict -6 default kod nomodify notrap nopeer noquery
restrict 127.0.0.1
restrict ::1

# Set up servers for ntpd with next options:
# server - IP address or DNS name of upstream NTP server
# iburst - allow send sync packages faster if upstream unavailable
# prefer - select preferrable server
# minpoll - set minimal update frequency
# maxpoll - set maximal update frequency
server 10.20.0.1 iburst minpoll 3

# Driftfile.
driftfile /var/lib/ntp/drift

Any ideas why this is happening?

ntpq: read: Connection refused

I deployed OPNFV Brahmaputra 1.0. After finishing deployment, I checked the status of ntp on one controller node. Ntp could not connect to server. The status of ntp service on ntp client and ntp server were normal. Then I restarted ntp service on client. It conneted a while but disconnected quickly. The ntp server is on jumpserver(ip: 10.20.0.1). The log is below:

root@node-41:~# ntpq -p
ntpq: read: Connection refused
root@node-41:~# service ntp status
* NTP server is running
root@node-41:~# service ntp restart
* Stopping NTP server ntpd                   [ OK ]   
* Starting NTP server ntpd                    [ OK ]
root@node-41:~# ntpq -p
 remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
*10.20.0.1       LOCAL(0)         9 u    1    8    1    0.130    2.362   0.004
root@node-41:~# ntpq -p
 remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
*10.20.0.1       LOCAL(0)         9 u    5    8    3    0.130    2.362   0.257
root@node-41:~# ntpq -p
ntpq: read: Connection refused

Here is content of ntp.conf.

root@node-41:/etc# cat ntp.conf
# ntp.conf: Managed by puppet.
#
# Enable next tinker options:
# panic - keep ntpd from panicking in the event of a large clock skew
# when a VM guest is suspended and resumed;
# stepout - allow ntpd change offset faster
tinker panic 0 stepout 5

disable monitor

# Permit time synchronization with our time source, but do not
# permit the source to query or modify the service on this system.
restrict -4 default kod nomodify notrap nopeer noquery
restrict -6 default kod nomodify notrap nopeer noquery
restrict 127.0.0.1
restrict ::1

# Set up servers for ntpd with next options:
# server - IP address or DNS name of upstream NTP server
# iburst - allow send sync packages faster if upstream unavailable
# prefer - select preferrable server
# minpoll - set minimal update frequency
# maxpoll - set maximal update frequency
server 10.20.0.1 iburst minpoll 3

# Driftfile.
driftfile /var/lib/ntp/drift

Any ideas why this is happening?