Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

private networking when deploying fuel-plugin-ovsnfv


After deploying an environment with fuel-plugin-ovsnfv plugin the private network is not working I found the following error in /tmp/ovs-vswitchd.log

2016-07-07T10:02:40Z|00089|dpif|WARN|failed to enumerate system datapaths: No such file or directory 2016-07-07T10:02:40Z|00090|dpif|WARN|failed to create datapath ovs-system: No such file or directory 2016-07-07T10:02:40Z|00091|ofproto_dpif|ERR|failed to open datapath of type system: No such file or directory 2016-07-07T10:02:40Z|00092|ofproto|ERR|failed to open datapath br-prv: No such file or directory 2016-07-07T10:02:40Z|00093|bridge|ERR|failed to create bridge br-prv: No such file or directory 2016-07-07T10:02:40Z|00094|bridge|INFO|ovs-vswitchd (Open vSwitch) 2.4.90

It seems that the br-prv is added without the option "-- set bridge br-prv datapath_type=netdev"

The ifc-br-prv looks as following auto br-prv allow-ovs br-prv iface br-prv inet manual ovstype OVSBridge ovsports p_e52381cd-0

When I run ovs-vsctl show I get the following 1081c417-bdc8-48e3-9051-a0269783f3d4 Bridge br-int failmode: secure Port int-br-prv Interface int-br-prv type: patch options: {peer=phy-br-prv} Port "int-br-ens9f0" Interface "int-br-ens9f0" type: patch options: {peer="phy-br-ens9f0"} Port br-int Interface br-int type: internal Bridge "br-ens9f0" Port "dpdk3" Interface "dpdk3" type: dpdk Port "br-ens9f0" Interface "br-ens9f0" type: internal Port "phy-br-ens9f0" Interface "phy-br-ens9f0" type: patch options: {peer="int-br-ens9f0"} Bridge br-prv Port "pe52381cd-0" Interface "pe52381cd-0" type: internal Port br-prv Interface br-prv type: internal Port phy-br-prv Interface phy-br-prv type: patch options: {peer=int-br-prv} ovsversion: "2.3.1"

But when I run "ip link" there is no interface br-prv and br-int is down 28: br-int: <broadcast,promisc> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 500 link/ether 5e:cf:b8:1d:92:42 brd ff:ff:ff:ff:ff:ff

Finaly when I run brctl show (see below) br-aux doesn't have the internal port (p_e52381cd-0) that connects it to the br-prv

bridge name bridge id STP enabled interfaces br-aux 8000.90e2ba7cae2a no enp129s0f2 br-fw-admin 8000.1418773b91d7 no eno1 br-mgmt 8000.90e2ba7cae2a no enp129s0f2.101 br-storage 8000.90e2ba7cae2a no enp129s0f2.102 virbr0 8000.525400ff860d yes virbr0-nic