Ask Your Question
0

Unable to connect to VM running Brahmaputra

asked 2016-05-26 11:08:18 -0700

aditya_mulgundkar gravatar image

updated 2016-05-26 11:09:55 -0700

I am trying to install Brahmaputra using Fuel, following this guide: http://artifacts.opnfv.org/fuel/brahm... Upon finishing the install process, i get the login screen with the default IP to access the fuel UI (10.20.0.2), but connecting to this IP from the host computer gives me a refused connection error.

I'm new to openstack, so I tried using commands like "fuel env" and "fuel nodes". These give me an error saying " can't connect to nailgun server. Please check configuration files."

So I'm confused here. Is this an issue with the build? Or with any of the networking steps that are followed before the installation? (I've tried a few iterations, but I've had the exact same results consistently)

Also. I have no clue how to log this. So please let me know if any log files are necessary to debug this issue.

Note: I can ping the IP, it gives me a reply. But i can't open it in the browser. I tried different variations of network adapters (I'm using virtualbox), as well as port forwarding. But it seems that the issue lies with the Brahmaputra build, as i can't ping www.google.com , or 8.8.8.8 from it either.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-05-27 01:18:29 -0700

dbalsige gravatar image

Hi there

I am using fuel as well. Are you trying to install to baremetal or you try it in a virtual setup ? What is your networking setup ?

If youre not able to ping 8.8.8.8 from the fuel server, you should maybe change the default settings to fit your network setup. As far as I understood the fuel server needs access to the Internet as well as a working name resolution by DNS. you can edit the network configuration files in /etc/sysconfig-network/ifcfg-* to add a valid DNS servers and interface configurations for your network. Of course you can also try to install fuel again and configure the needed network settings in the setup menu.

D

edit flag offensive delete link more

Comments

Running it on a Virtual Machine, but i've tried building it on bare metal as well. Have the same issue in both cases. Also, I have tried editing the /etc/sysconfig-network/ifcfg-eth0 and /etc/sysconfig-network/ifcfg-eth1 files, with no luck. How would you describe a "valid" DNS config?

aditya_mulgundkar ( 2016-05-27 02:28:07 -0700 )edit
0

answered 2016-05-30 03:47:40 -0700

lmcdasm gravatar image

Hello.

im not sure why you would edit those on the nodes manually, they are defined in fuel when you install fuel (fuelmenu) and when you define your environment (for deployment and run verify).

A valid DNS configuration is one that allows you to do "nslookup www.google.ca" for exampe and get the IP address from the Name Server - basically it allows your node to get to the internet. If you arent able to do simple hostname resolution, then I suspect you have your virtualbox setup for a networking mode other than Bridged (meaning that your FUEL gets an IP on the same subnet as your host).

edit flag offensive delete link more

Comments

It turns out, the services under docker take a little while to load. So, the UI is only available when all the services have started up. Also, I solved the nailgun not working problem by downloading the ISO file again (Turns out, mine was corrupt/ interrupted). Thanks anyways.

aditya_mulgundkar ( 2016-05-30 03:53:19 -0700 )edit

hey there.. glad to hear you got it working .. depending on the CPU/RAM you give Fuel, and the disk it can take some time (5 minutes in some cases0. Cheer,s

lmcdasm ( 2016-05-31 03:39:34 -0700 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
1 follower

Stats

Asked: 2016-05-26 11:08:18 -0700

Seen: 270 times

Last updated: May 30 '16