Ask Your Question
0

unable to boot OS on host1 and host2 using jumphost?

asked 2016-05-16 18:35:18 -0700

shabari gravatar image

Hai,

We are trying to install OPNFV Brahmaputra with one jumphost and 2 hosts(host1 and host2). We are able to run the scripts successfully. As it shows following


* TASK COMPLETE * + reboot_hosts + '[' -z /home/v435621/compass4nfv/work/deploy/script/ipmitool.sh ']' + /home/v435621/compass4nfv/work/deploy/script/ipmitool.sh set pxe and reset 10.1.172.3 successsully + exit 1 root@VSdeV34:/home/v435621/compass4nfv# set pxe and reset 10.1.172.4 successsully


  1. As part of our Don’t know the following AssertError is a major issue or not: AssertionError
  2. RET=1
  3. sleep 25
  4. rename_nics
  5. python /home/v435621/compass4nfv/deploy/rename nics.py /home/v435621/myBM/dha.yml /home/v435621/compass4nfv/work/deploy/vm/compass/boot.rsa 10.2.200.2 ssh -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null -i /home/v435621/compass4nfv/work/deploy/vm/compass/boot.rsa root@10.2.200.2 'cobbler system edit --name=host1 --interface=eth1 --mac=9c:8e:99:0b:cc:b9' Warning: Permanently added '10.2.200.2' (ECDSA) to the list of known hosts. exception on server: 'internal error, unknown system name host1' ssh -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null -i /home/v435621/compass4nfv/work/deploy/vm/compass/boot.rsa root@10.2.200.2 'cobbler system edit --name=host2 --interface=eth1 --mac=80:c1:6e:24:79:63' Warning: Permanently added '10.2.200.2' (ECDSA) to the list of known hosts. exception on server: 'internal error, unknown system name host2' ssh -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null -i /home/v435621/compass4nfv/work/deploy/vm/compass/boot.rsa root@10.2.200.2 'cobbler sync' Warning: Permanently added '10.2.200.2' (ECDSA) to the list of known hosts. Ref: /home/v435621/compass4nfv/deploy/rename nics.py
edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2016-05-17 06:51:19 -0700

lmcdasm gravatar image

hell.

As outlined in the previous ticket, the issue is that you have not placed yoru FUEL vm on a linux bridge that is propagting to your other hosts.

if you have a JUMPHOST with (for example) two NICs. NIC-A and NIC-B.

NIC-A is targetting for your PXE bootin your environment, so this NIC-A should be encapsulated in a bridge on your JUMPHOST that included NIC-A and the vnet of your FUEL node.

This NIC1 - shoudl be on an untagged network that can has the other HOSTS associated to it.

Again, please send brctl show fro your jumphost as well as a diagram showing how you have the hosts connected to your physical switch.

edit flag offensive delete link more

Comments

Hai, Thanks fro your responds. Im installing OPNFV Brahmaputra compass version not Fuel Here is my brctl show o/p: bridge name bridge id STP enabled interfaces br_mgmt 8000.5254001bcdf0 yes br_mgmt-nic virbr0 8000.000000000000 ye

shabari ( 2016-05-18 11:21:08 -0700 )edit
0

answered 2016-06-03 07:52:14 -0700

shabari gravatar image

By enabling eth0 (PXE nic) and enabling port fast on port in the switch will resolve the issue.

Thanks

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Stats

Asked: 2016-05-16 18:35:18 -0700

Seen: 175 times

Last updated: Jun 03 '16