Ask Your Question
0

joid install jumphost

asked 2016-05-08 16:33:13 -0700

huilan gravatar image

uses the JOID installer config for the 3-node, single-NIC, non-HA, when I start MAAS ./02-maasdeploy.sh attvirpod1

it shows the error message 2016-05-08 18:14:09,934 DEBUG Creating cloud-init seed image for MAAS...

2016-05-08 18:14:09,936 INFO Seed volume 'opnfv-maas-att-seed.img' already exists

2016-05-08 18:14:09,936 INFO Deleting volume 'opnfv-maas-att-seed.img' before create since force=True

2016-05-08 18:14:09,936 DEBUG Executing: 'virsh -c qemu:///system vol-delete --pool default opnfv-maas-att-seed.img' stdin=''

2016-05-08 18:14:09,972 DEBUG Generating mime-multipart user data file using: ['write-mime-multipart', '--output=/tmp/tmpIosBxq/user-data.txt', '/tmp/tmpIosBxq/cloud-init.cfg', '/tmp/tmpIosBxq/config-maas.sh:text/x-shellscript']

2016-05-08 18:14:09,972 DEBUG Executing: 'write-mime-multipart --output=/tmp/tmpIosBxq/user-data.txt /tmp/tmpIosBxq/cloud-init.cfg /tmp/tmpIosBxq/config-maas.sh:text/x-shellscript' stdin=''

2016-05-08 18:14:10,017 DEBUG Creating local seed file

2016-05-08 18:14:10,017 DEBUG Executing: 'cloud-localds /tmp/tmpIosBxq/opnfv-maas-att-seed.img /tmp/tmpIosBxq/user-data.txt /tmp/tmpIosBxq/meta-data' stdin=''

2016-05-08 18:14:10,045 DEBUG Creating volume

2016-05-08 18:14:10,045 DEBUG Executing: 'virsh -c qemu:///system vol-create-as --pool default --name opnfv-maas-att-seed.img --capacity 376832 --format raw' stdin=''

2016-05-08 18:14:10,093 DEBUG Uploading seed /tmp/tmpIosBxq/opnfv-maas-att-seed.img to volume...

2016-05-08 18:14:10,094 DEBUG Executing: 'virsh -c qemu:///system vol-upload --pool default --file /tmp/tmpIosBxq/opnfv-maas-att-seed.img --vol opnfv-maas-att-seed.img' stdin=''

2016-05-08 18:14:10,168 DEBUG Executing: 'virt-install --connect qemu:///system --name opnfv-maas-att --ram 4096 --vcpus 2 --disk vol=default/opnfv-maas-att-root.img,format=qcow2,bus=virtio,io=native --disk vol=default/opnfv-maas-att-seed.img,format=raw,bus=virtio,io=native --network bridge=brAdm,model=virtio --noautoconsole --vnc --import' stdin=''

2016-05-08 18:14:12,238 DEBUG Executing: 'virsh -c qemu:///system autostart opnfv-maas-att' stdin=''

2016-05-08 18:14:12,258 DEBUG Waiting for MAAS vm to come up for ssh..

2016-05-08 18:14:12,258 DEBUG Using ip address specified: 192.168.10.3

2016-05-08 18:14:12,259 DEBUG Executing: 'ssh -i /home/opnfv/.ssh/id_maas -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no opnfv@192.168.10.3 true' stdin=''

2016-05-08 18:14:15,266 DEBUG Waiting for MAAS vm to start.

2016-05-08 18:14:16,267 DEBUG Executing: 'ssh -i /home/opnfv/.ssh/id_maas -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no opnfv@192.168.10.3 true' stdin=''

2016-05-08 18:14:18,266 DEBUG Waiting for MAAS vm to start.

What is the problem?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2016-05-09 17:35:48 -0700

huilan gravatar image

Set the correct VM IP address in the file ~/joid/ci/maas/att/virpod1/deployment.yaml Then ping Mass VM ip in order to make sure it is alive....


    # Virsh power settings
       # Specifies the uri and keys to use for virsh power control of the 
       # juju virtual machine. If the uri is omitted, the value for the
       # --remote is used. If no power settings are desired, then do not
       # supply the virsh block.
       virsh:
        rsa_priv_key: /home/ubuntu/.ssh/id_rsa
        rsa_pub_key: /home/ubuntu/.ssh/id_rsa.pub
        uri: qemu+ssh://ubuntu@192.168.10.3/system

    # Defines the IP Address that the configuration script will use to
    # to access the MAAS controller via SSH.
    ip_address: 192.168.10.3
edit flag offensive delete link more

Comments

awesome.. thanks! do you think a bug should be placed in JIRA (a ticket) to fix it permanently? Cheers, D

lmcdasm ( 2016-05-09 18:11:08 -0700 )edit
0

answered 2016-05-09 04:04:55 -0700

lmcdasm gravatar image

Hello.

Im not a JOID Expert, but it seems that your VM failed to start.

can you do a virsh list (assuming KVM is your base) or equivalent command to see what VMs are running?

Can you confirm that your physical HOST is a baremetal host with suffiient resources to start the VM? Are you using VirtualBox ? (since it doesnt allow for nested virtualization).

again - just some guess of where i would start to look. - maybe test that you can create the machine by hand (doing the command output above) and see what errors/where it breaks as you step through them.

Hope that helps! Daniel

edit flag offensive delete link more

Comments

hi Daniel, Thanks for your quick reply, I check the vm is running well, but it is still waiting maas vm start?.... virsh # list Id Name State 9 opnfv-maas-att running huilan

huilan ( 2016-05-09 07:14:50 -0700 )edit

I modify the deployment.yam then maas vm is started ,

huilan ( 2016-05-09 10:01:45 -0700 )edit

great to hear :). - Can you post the modifications that you did so that we have a reference? maybe someone else has the same issue. Cheers, D

lmcdasm ( 2016-05-09 13:12:41 -0700 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
1 follower

Stats

Asked: 2016-05-08 16:33:13 -0700

Seen: 47 times

Last updated: May 09 '16