Ask Your Question
0

Fuel GUI loads indefinitely [closed]

asked 2015-09-14 05:00:31 -0700

Deivarayan gravatar image

updated 2015-09-14 07:41:40 -0700

Hello,

I am trying to install Arno using Fuel deployment.

I have 4 nodes in my topology.

1 Fuel master, 2 Controller nodes and 1 compute node. Each of the nodes runs on different virtual machines with a overall disk space of 2 TB and RAM of 8GB.

Also, i have 3 networks. Admin, private and public respectively.

I've succesfully installed fuel Master. DHCP, DNS and NTP are fine with no errors. After which, i tried to open Fuel GUI from my host system with url: 192.168.50.71:8000 (I am able to ping the ip 192.168.50.71 from my host system) for creating openstack environment, Fuel welcome screen appeared and it loads indefinitely (Its been almost more than 2 hours) with no response.

Could someone please let me know the reason for this indefinite loading? Is it due to low RAM of 8GB ?

Thanks in advance!!!!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Deivarayan
close date 2015-09-16 06:52:17

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-09-14 06:01:13 -0700

lmcdasm gravatar image

updated 2015-09-15 05:58:42 -0700

hello.

can you please provide a bit more information?

Can you give us a ifconfig -a output, netstat -rn and netstat -na output from the FUEL master console.

when you say DNS, NTP and NAT are fine - what NAT do you mean? Are you natting from one address to another? Did you perform the configuration step of FUEL or just install by default.?

From your output it seems you are missing the default route, since you have multiple resources, you need to specify a default route so that the return packet when you make a HTTP GET to the FUEL GUI knows where to go.

D

edit flag offensive delete link more

Comments

Hello, Thank you so much for your quick response. I am not using any NAT functionality. I wrongly typed NAT instead of DNS. I am so sorry for that. I am following the FUEL configuration steps from the below link. artifacts.opnfv.org/arno.2015.1.0/fuel/install-guide.arno.2015.1.0.pdf Thanks

Deivarayan ( 2015-09-14 07:26:19 -0700 )edit
0

answered 2015-09-14 07:37:02 -0700

Deivarayan gravatar image

Hello,

Please find the outputs of the first 2 commands below. 3rd one is quite big to fit (with format).

[root@fuel ~]# ifconfig -a

docker0 Link encap:Ethernet HWaddr FE:5D:82:8B:1A:EF

      inet addr:172.17.42.1  Bcast:0.0.0.0  Mask:255.255.0.0
      inet6 addr: fe80::703a:4ff:fe8a:e69f/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:108 errors:0 dropped:0 overruns:0 frame:0
      TX packets:65 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0
      RX bytes:6240 (6.0 KiB)  TX bytes:5826 (5.6 KiB)

eth0 Link encap:Ethernet HWaddr 08:00:27:62:98:5A

      inet addr:192.168.50.71  Bcast:192.168.255.255  Mask:255.255.0.0
      inet6 addr: fe80::a00:27ff:fe62:985a/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:1412 errors:0 dropped:0 overruns:0 frame:0
      TX packets:68 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000
      RX bytes:106812 (104.3 KiB)  TX bytes:12710 (12.4 KiB)

eth1 Link encap:Ethernet HWaddr 08:00:27:88:42:64

      inet addr:10.4.8.2  Bcast:10.4.15.255  Mask:255.255.248.0
      inet6 addr: fe80::a00:27ff:fe88:4264/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:34 errors:0 dropped:0 overruns:0 frame:0
      TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000
      RX bytes:2938 (2.8 KiB)  TX bytes:636 (636.0 b)

eth2 Link encap:Ethernet HWaddr 08:00:27:F3:0F:72

      inet addr:10.4.16.2  Bcast:10.4.23.255  Mask:255.255.248.0
      inet6 addr: fe80::a00:27ff:fef3:f72/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:34 errors:0 dropped:0 overruns:0 frame:0
      TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000
      RX bytes:2938 (2.8 KiB)  TX bytes:636 (636.0 b)

lo Link encap:Local Loopback

      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0
      RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

vethHGBHLP Link encap:Ethernet HWaddr FE:87:1C:5E:E9:BB

      inet6 addr: fe80::fc87:1cff:fe5e:e9bb/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:32 errors:0 dropped:0 overruns:0 frame:0
      TX packets:125 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000
      RX bytes:2328 (2.2 KiB)  TX bytes:9490 (9.2 KiB)

vethVQH2m0 Link encap:Ethernet HWaddr FE:83:3A:26:5F ... (more)

edit flag offensive delete link more

Comments

Hey there.. Looking at the route, you are missing a Default Route there - this is pretty common when you add more than one network into your FUEL VM - since when you set different IPs' in the configuration screen, your default route is good. You need to add "route add default gw <ip>" in your FUEL

lmcdasm ( 2015-09-15 05:55:24 -0700 )edit

VM and you will be able to route out. You should have something like: Kernel IP routing table Destination Gateway Genmask Flags MSS Window irtt Iface 0.0.0.0 10.118.36.1 255.255.255.0 U 0 0 0 eth1 <other output="" truncated="">

lmcdasm ( 2015-09-15 05:57:13 -0700 )edit

Thank you so much!!!

Deivarayan ( 2015-09-16 06:51:40 -0700 )edit

You're welcome! - Please upvote the answer :)

lmcdasm ( 2015-09-16 20:58:42 -0700 )edit

Question Tools

Follow
1 follower

Stats

Asked: 2015-09-14 05:00:31 -0700

Seen: 171 times

Last updated: Sep 15 '15