Ask Your Question
0

Error in deploying OPNFV ARNO via Fuel

asked 2016-01-04 23:45:01 -0700

sature gravatar image

Hi there,

I'm following the installation guide (install-guide.arno.2015.2.0.pdf) to deploy opnfv via fuel, while with several tries I always met issue described below.

It's appreciated if any one could hep to figure out what's the problem, thanks!

Setup:

  • All the nodes including jump server are virtual machines created by vSphere ESXi
  • Jump server with Internet access (behind proxy)
  • 6 Servers: 3 x Controller+CephOSD, 2 x Compute, 1 x Telemetry MongoDB
  • 3 LANs: eth0 - PXE, eth1 - public, eth2 - Storage(102), Mgmt(101),Private(103)

Configuration (everything with specific options as following):

  • Openstack Juno on Ubuntu 14.04
  • Hypervisor: QEMU w/o vCenter checked
  • Using local repository
  • Using my company DNS, NTP server as Host/Guest OS DNS and Host OS NTP

Finished configuration, verified network, and when I starting deploying

  • I would see 'Ubuntu is installed' on all 6 nodes
  • While it reports ERROR on the telemetry node
  • Tried several times and the same issue occurred.

By inspecting Astute log, it report error as below:

2016-01-05 06:55:55 ERR [600] Error running RPC method granulardeploy: Deployment failed on nodes 6, trace: ["/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/deploymentengine.rb:68:in block (3 levels) in deploy'", "/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/deployment_engine.rb:51:ineachslice'", "/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/deploymentengine.rb:51:in block (2 levels) in deploy'", "/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/deployment_engine.rb:49:ineach'", "/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/deploymentengine.rb:49:in block in deploy'", "/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/deployment_engine.rb:45:ineach'", "/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/deploymentengine.rb:45:in deploy'", "/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/orchestrator.rb:179:indeploycluster'", "/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/orchestrator.rb:56:in granular_deploy'", "/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/server/dispatcher.rb:111:ingranulardeploy'", "/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/server/server.rb:142:in dispatch_message'", "/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/server/server.rb:103:inblock in dispatch'", "/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/server/taskqueue.rb:64:in call'", "/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/server/task_queue.rb:64:inblock in each'", "/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/server/taskqueue.rb:56:in each'", "/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1 ... (more)

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-01-06 23:43:09 -0700

sature gravatar image

maybe I could close this question by myself. there is no problem without I execute fuel-createmirror before using the local repository.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
1 follower

Stats

Asked: 2016-01-04 23:45:01 -0700

Seen: 186 times

Last updated: Jan 06 '16