Ask Your Question
0

Failed to deploy opendaylight

asked 2015-12-01 08:13:47 -0700

kej gravatar image

Hello,

Thanks to your help, I could install "Arno SR1-fuel" and openstack (1 compute and 1 controller) eventually. But, while deploying opendaylight, it failed.

Here is the error message: Error Deployment has failed. Method granulardeploy... parameters: puppetmodiules: puppet/modules:/etc/puppet... timeout: 60 cwd: "/etc/fuel/plugins/opendaylight-0.6.1"

My question is that when I checked the folder "/etc/fuel/plugins/opendaylight-0.6.1", there was no such folder or file. Before deploying, I installed plugin, but /etc/fuel/plugins/ folder wasn't created. I executed the command "fuel plugins --install /opt/opnfv/opendaylight-0.6-0.6.1-1.noarch.rpm" and output was fine. "output: "Plugin opendaylight-0.6-0.6.1-1.noarch.rpm was successfully installed."

Here is detailed information of my system: All computers (Fuel, Compute, Controller) are real computer running centos Both NTP and Gateway access were fine. Verifying network was fine. According to the "install-guide-arno.2015.2.0.pdf", I selected the following options on the Fuel GUI: KVM, Neutron with GRE segmentation, OpenDaylight Lithium Plugin, VXLAN Also, I built local mirror on Fuel (with Centos) using the following command: fuel-package-updates -d centos-security -r 2014.2.2-6.1 //mos-security fuel-package-updates -d centos -r 2014.2.2-6.1 //mos-updates

If you can give me any information about this error, it would be really great. Thank you, Kim

edit retag flag offensive close merge delete

Comments

Hi, can you please ssh to one of the nodes where deployment failed and provide last lines of /var/log/puppet.log file where you see errors - you can use http://paste.openstack.org/ to share content. Directory /etc/fuel/plugins/opendaylight-0.6.1 is created on slave nodes not on the fuel master.

mskalski ( 2015-12-01 14:54:48 -0700 )edit

3 answers

Sort by ยป oldest newest most voted
1

answered 2015-12-02 14:56:33 -0700

mskalski gravatar image

Ok, so you are deploying Ubuntu environment. Plugin shipped on Arno SR1 Fuel ISO include some dependencies which are compatible with packages which can be found in local mirrors. If you are using upstream mirrors then newer packages are available which interfere with this one included in plugins. You can:

  • setup local mirrors, how to do that you can find in installation guide
  • before deployment in settings tab set higher priority like 2000 for those repositories which have no priority defined and keep mos repos with highest priority. Default priority for plugin repositories is 1100. This should prevent installation packages from plugin repository if there are newer version in upstream. image description
  • build plugin without including packages from source from 6.1 branch
edit flag offensive delete link more
0

answered 2015-12-02 10:24:12 -0700

kej gravatar image

updated 2015-12-02 10:39:43 -0700

Thank you for your response. Here is the message and I will upload the file, too. Thank you, Kim

=== Message=== The following packages have unmet dependencies: openjdk-7-jre-headless : Depends: tzdata-java but it is not going to be installed E: Unable to correct problems, you have held broken packages.

/usr/lib/ruby/vendorruby/puppet/util/execution.rb:188:in execute' /usr/lib/ruby/vendor_ruby/puppet/provider/command.rb:23:inexecute' /usr/lib/ruby/vendorruby/puppet/provider.rb:237:in block in has_command' /usr/lib/ruby/vendor_ruby/puppet/provider.rb:444:inblock in createclassandinstancemethod' /usr/lib/ruby/vendorruby/puppet/provider/package/apt.rb:68:in install' /usr/lib/ruby/vendor_ruby/puppet/type/package.rb:67:inblock (3 levels) in <module:puppet>' /usr/lib/ruby/vendorruby/puppet/property.rb:197:in call_valuemethod' /usr/lib/ruby/vendor_ruby/puppet/property.rb:498:inset' /usr/lib/ruby/vendorruby/puppet/property.rb:581:in sync' /usr/lib/ruby/vendor_ruby/puppet/transaction/resource_harness.rb:191:insync' /usr/lib/ruby/vendorruby/puppet/transaction/resourceharness.rb:128:in sync_if_needed' /usr/lib/ruby/vendor_ruby/puppet/transaction/resource_harness.rb:81:inperformchanges' /usr/lib/ruby/vendorruby/puppet/transaction/resourceharness.rb:20:in evaluate' /usr/lib/ruby/vendor_ruby/puppet/transaction.rb:174:inapply' /usr/lib/ruby/vendorruby/puppet/transaction.rb:187:in eval_resource' /usr/lib/ruby/vendor_ruby/puppet/transaction.rb:117:incall' /usr/lib/ruby/vendorruby/puppet/transaction.rb:117:in block (2 levels) in evaluate' /usr/lib/ruby/vendor_ruby/puppet/util.rb:327:inblock in thinmark' /usr/lib/ruby/1.9.1/benchmark.rb:295:in realtime' /usr/lib/ruby/vendor_ruby/puppet/util.rb:326:inthinmark' /usr/lib/ruby/vendorruby/puppet/transaction.rb:117:in block in evaluate' /usr/lib/ruby/vendor_ruby/puppet/graph/relationship_graph.rb:118:intraverse' /usr/lib/ruby/vendorruby/puppet/transaction.rb:108:in evaluate' /usr/lib/ruby/vendor_ruby/puppet/resource/catalog.rb:164:inblock in apply' /usr/lib/ruby/vendorruby/puppet/util/log.rb:149:in with_destination' /usr/lib/ruby/vendor_ruby/puppet/transaction/report.rb:108:inasloggingdestination' /usr/lib/ruby/vendorruby/puppet/resource/catalog.rb:163:in apply' /usr/lib/ruby/vendor_ruby/puppet/configurer.rb:125:inblock in applycatalog' /usr/lib/ruby/vendorruby/puppet/util.rb:161:in block in benchmark' /usr/lib/ruby/1.9.1/benchmark.rb:295:inrealtime' /usr/lib/ruby/vendorruby/puppet/util.rb:160:in benchmark' /usr/lib/ruby/vendor_ruby/puppet/configurer.rb:124:inapplycatalog' /usr/lib/ruby/vendorruby/puppet/configurer.rb:192:in run' /usr/lib/ruby/vendor_ruby/puppet/application/apply.rb:268:inapplycatalog' /usr/lib/ruby/vendorruby/puppet/application/apply.rb:218:in main' /usr/lib/ruby/vendor_ruby/puppet/application/apply.rb:146:inruncommand' /usr/lib/ruby/vendorruby/puppet/application.rb:364:in block (2 levels) in run' /usr/lib/ruby/vendor_ruby/puppet/application ... (more)

edit flag offensive delete link more
0

answered 2016-01-06 04:34:29 -0700

leopoldo gravatar image

updated 2016-01-06 04:36:54 -0700

I had the same problem. So I have followed the instructions (setting up local mirror and changing repository priorities). However, a new problem is happening:

ERROR

Deployment has failed. Method granulardeploy. Failed to execute hook 'shell' Failed to run command cd / && ruby /etc/puppet/modules/osnailyfacter/modular/astute/cephready_check.rb Task: 240ff385-f1ec-455c-80e8-9a38d1bf3b72: shell timeout error: execution expired Task timeout: 1800, Retries:

priority: 600 failonerror: true type: shell uids: - '14' parameters: cmd: ruby /etc/puppet/modules/osnailyfacter/modular/astute/cephreadycheck.rb timeout: 1800 .*

Inside de node where deployment failed, after I've executed the command "ruby /etc/puppet/modules/osnailyfacter/modular/astute/cephreadycheck.rb", I saw that error:

root@node-12:~# ruby /etc/puppet/modules/osnailyfacter/modular/astute/cephreadycheck.rb try 0 ok There are PGs which are not in active state! try 1 ok There are PGs which are not in active state! try 2 ok There are PGs which are not in active state! try 3 ok There are PGs which are not in active state! try 4 ok .. ..

If you could give me any information about this error, I would be greatfull

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
1 follower

Stats

Asked: 2015-12-01 08:13:47 -0700

Seen: 839 times

Last updated: Jan 06 '16