Ask Your Question
0

ERROR while deploying Openstack Environment with Arno Fuel

asked 2015-11-19 07:04:41 -0700

srik1782 gravatar image

Hi, I am trying to deploy following Openstack Environment: Node1: Controller + Storage - Ceph OSD Node2: Compute + Storage - Ceph OSD Node3: Telemetry Mongo DB

Actually, I want an environment with only one Controller and one Compute Node. But, FUEL GUI throwing some error while deploying, I am forced to select the above environment.

But, however, I am getting the following error while deplying:

2015-11-19 19:28:06 ERR (/Stage[main]/Main/Cluster::Virtualipping[vippublic]/Service[vippublic]/ensure) change from stopped to running failed: Execution timeout after 600 seconds! 2015-11-19 19:28:06 ERR /usr/bin/puppet:4:in <main>' 2015-11-19 19:28:06 ERR /usr/lib/ruby/vendor_ruby/puppet/util/command_line.rb:91:inexecute' 2015-11-19 19:28:06 ERR /usr/lib/ruby/vendorruby/puppet/util/commandline.rb:137:in run' 2015-11-19 19:28:06 ERR /usr/lib/ruby/vendor_ruby/puppet/application.rb:364:inrun' 2015-11-19 19:28:06 ERR /usr/lib/ruby/vendorruby/puppet/util.rb:478:in exit_on_fail' 2015-11-19 19:28:06 ERR /usr/lib/ruby/vendor_ruby/puppet/application.rb:364:inblock in run' 2015-11-19 19:28:06 ERR /usr/lib/ruby/vendorruby/puppet/application.rb:470:in plugin_hook' 2015-11-19 19:28:06 ERR /usr/lib/ruby/vendor_ruby/puppet/application.rb:364:inblock (2 levels) in run' 2015-11-19 19:28:06 ERR /usr/lib/ruby/vendorruby/puppet/application/apply.rb:146:in run_command' 2015-11-19 19:28:06 ERR /usr/lib/ruby/vendor_ruby/puppet/application/apply.rb:218:inmain' 2015-11-19 19:28:06 ERR /usr/lib/ruby/vendorruby/puppet/application/apply.rb:268:in apply_catalog' 2015-11-19 19:28:06 ERR /usr/lib/ruby/vendor_ruby/puppet/configurer.rb:192:inrun' 2015-11-19 19:28:06 ERR /usr/lib/ruby/vendorruby/puppet/configurer.rb:124:in apply_catalog' 2015-11-19 19:28:06 ERR /usr/lib/ruby/vendor_ruby/puppet/util.rb:160:inbenchmark' 2015-11-19 19:28:06 ERR /usr/lib/ruby/1.9.1/benchmark.rb:295:in realtime' 2015-11-19 19:28:06 ERR /usr/lib/ruby/vendor_ruby/puppet/util.rb:161:inblock in benchmark' 2015-11-19 19:28:06 ERR /usr/lib/ruby/vendorruby/puppet/configurer.rb:125:in block in apply_catalog' 2015-11-19 19:28:06 ERR /usr/lib/ruby/vendor_ruby/puppet/resource/catalog.rb:163:inapply' 2015-11-19 19:28:06 ERR /usr/lib/ruby/vendorruby/puppet/transaction/report.rb:108:in as_logging_destination' 2015-11-19 19:28:06 ERR /usr/lib/ruby/vendor_ruby/puppet/util/log.rb:149:inwithdestination' 2015-11-19 19:28:06 ERR /usr/lib/ruby/vendorruby/puppet/resource/catalog.rb:164:in block in apply' 2015-11-19 19:28:06 ERR /usr/lib/ruby/vendor_ruby/puppet/transaction.rb:108:inevaluate' 2015-11-19 19:28:06 ERR /usr/lib/ruby/vendorruby/puppet/graph/relationshipgraph.rb:118:in traverse' 2015-11-19 19:28:06 ERR /usr/lib/ruby/vendor_ruby/puppet/transaction.rb:117:inblock in evaluate' 2015-11-19 19:28:06 ERR /usr/lib/ruby/vendorruby/puppet/util.rb:326:in ... (more)

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-11-20 13:03:58 -0700

mskalski gravatar image

Hi,

Please make sure that the gateway which you configure for public network is reachable - you can ping it from controller and computes nodes.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
1 follower

Stats

Asked: 2015-11-19 07:04:41 -0700

Seen: 1,643 times

Last updated: Nov 20 '15