Ask Your Question
0

Deployment failed with Arno SR1 (with ODL) [closed]

asked 2015-10-16 09:58:19 -0700

Deivarayan gravatar image

updated 2015-10-16 09:59:04 -0700

Hi,

I have a 2 node setup (1 Controller with Cinder and 1 compute node) with ODL plugin. I followed local repository method.Verify networks were successful.

All nodes have NTP server access but internet connectivity is available in only Fuel (Controller and compute node does not have internet connectivity). I added a static route in controller and compute nodes to access NTP server.

I got the following error during deployment.

2015-10-16 16:41:04 ERR (/Stage[main]/Main/Cluster::Virtualip[public]/Service[vip_public]/ensure) change from stopped to running failed: Execution timeout after 600 seconds!

2015-10-16 16:41:04 ERR /usr/bin/puppet:4

2015-10-16 16:41:04 ERR /usr/lib/ruby/siteruby/1.8/puppet/util/commandline.rb:91:in `execute'

2015-10-16 16:41:04 ERR /usr/lib/ruby/siteruby/1.8/puppet/util/commandline.rb:137:in `run'

2015-10-16 16:41:04 ERR /usr/lib/ruby/site_ruby/1.8/puppet/application.rb:364:in `run'

2015-10-16 16:41:04 ERR /usr/lib/ruby/siteruby/1.8/puppet/util.rb:478:in `exiton_fail'

2015-10-16 16:41:04 ERR /usr/lib/ruby/site_ruby/1.8/puppet/application.rb:364:in `run'

2015-10-16 16:41:04 ERR /usr/lib/ruby/siteruby/1.8/puppet/application.rb:470:in `pluginhook'

2015-10-16 16:41:04 ERR /usr/lib/ruby/site_ruby/1.8/puppet/application.rb:364:in `run'

2015-10-16 16:41:04 ERR /usr/lib/ruby/siteruby/1.8/puppet/application/apply.rb:146:in `runcommand'

2015-10-16 16:41:04 ERR /usr/lib/ruby/site_ruby/1.8/puppet/application/apply.rb:218:in `main'

2015-10-16 16:41:04 ERR /usr/lib/ruby/siteruby/1.8/puppet/application/apply.rb:268:in `applycatalog'

2015-10-16 16:41:04 ERR /usr/lib/ruby/site_ruby/1.8/puppet/configurer.rb:192:in `run'

My default gateway in controller node was not pingable (Public ip), So i changed the default gateway to my fuel admin ip. But still, the error occurs. Could someone please help me in solving this error.

Thanks in advance!!!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Deivarayan
close date 2015-10-22 08:06:40

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-10-16 14:40:49 -0700

mskalski gravatar image

updated 2015-10-20 10:59:26 -0700

Hi,

IP of the public network gateway which you defined in Fuel settings must be pingable. If you can't configure it on your network devices, just create additional interface on Fuel master which will be in the public network vlan and assign to this interface IP address of the public gateway.

Update regarding timeout

It looks like puppet run for one of the tasks not finished in defined time. Couple days ago I increased timeout value in this commit [1], but version of the plugin on Arno SR1 iso doesn't include it. You can check how much time it took on your environment to run puppet/manifests/recreate-neutron-db.pp manifest in /var/log/puppet.log file on controller node. I compiled for you plugin version which include increased timeout value, you can grab it from here [2] - this version is for ubuntu evironment where you have access to internet from slave nodes. Before installation remove old plugin:

fuel plugins --remove opendaylight==0.6.1

and install new one.

Regarding problems with ntp synchronization, could you check if you can run ntpdate command pointing to one of your ntp servers and it will end with success?

[1] https://github.com/openstack/fuel-plu...

[2] http://devel.opt.im/opendaylight-0.6-...

edit flag offensive delete link more

Comments

Thank you so much for your advice. I solved that problem. But i am getting another error during ODL integration. Please find the error message below. Its the same error as faced by threesmaller in the other thread. I had this error twice. It looks am missing something. Kindly advice

Deivarayan ( 2015-10-19 06:29:05 -0700 )edit

Verify networks was successful

Deivarayan ( 2015-10-19 07:08:03 -0700 )edit

Thank you so much for your reply. Could you please let me know whether i can use the new opendaylight plugin for Centos installation with local repo? I have internet access only to my fuel node. Controller and compute nodes does not have internet connectivity (to avoid DHCP server conflicts)

Deivarayan ( 2015-10-21 02:18:26 -0700 )edit

Plugin for offline deploy is quite big but you can build it for yourself as it is described here https://github.com/openstack/fuel-plugin-opendaylight#dependencies.

mskalski ( 2015-10-21 06:33:32 -0700 )edit

If you will have problems with that write to me https://github.com/openstack/fuel-plugin-opendaylight#contributors and I will share this version for you.

mskalski ( 2015-10-21 06:34:39 -0700 )edit
0

answered 2015-10-19 06:30:25 -0700

Deivarayan gravatar image

updated 2015-10-20 10:22:49 -0700

I tried with all sort of combinations. Every time i end up with the error in "recreate-neutron-db.pp" :(.

My set up (1 Controller with cinder and 1 compute node): Tried with both VXLAN and GRE segmentation

Fuel - runs on a virtual machine

Controller+Cinder and compute - bare metal

Controller - 500 GB, 8GB RAM

Compute - 700 GB, 32 GB RAM

Please find the error below (taken from Astute logs)

[552] Error running RPC method granular_deploy: Failed to execute hook 'opendaylight-0.6.1' Puppet run failed. Check puppet logs for details

uids: - '6'

parameters:

puppet_modules: puppet/modules:/etc/puppet/modules

puppet_manifest: puppet/manifests/recreate-neutron-db.pp

timeout: 60

cwd: "/etc/fuel/plugins/opendaylight-0.6/"

priority: 1900

failonerror: true

type: puppet diagnostic_name: opendaylight-0.6.1 , trace:

["/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/nailgun_hooks.rb:58:in `block in process'",

"/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/nailgun_hooks.rb:26:in `each'",

"/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/nailgun_hooks.rb:26:in `process'",

"/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/deploymentengine/granulardeployment.rb:221:in `postdeploymentactions'",

"/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/deployment_engine.rb:75:in `deploy'",

"/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/orchestrator.rb:179:in `deploy_cluster'",

"/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/orchestrator.rb:56:in `granular_deploy'",

"/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/server/dispatcher.rb:111:in `granular_deploy'",

"/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/server/server.rb:142:in `dispatch_message'",

"/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/server/server.rb:103:in `block in dispatch'",

"/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/server/task_queue.rb:64:in `call'",

"/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/server/task_queue.rb:64:in `block in each'",

"/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/server/task_queue.rb:56:in `each'",

"/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/server/task_queue.rb:56:in `each'",

"/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/server/server.rb:101:in `eachwithindex'",

"/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/lib/astute/server/server.rb:101:in `dispatch'",

"/usr/lib64/ruby/gems/2.1.0/gems/astute-6.1.0/

I have access to NTP servers from all the nodes.

[root@node-13 ~]# ip netns exec vrouter ntpq -c lpeer

 remote           refid      st t when poll reach   delay   offset  jitter

==============================================================================

*fuel.domain.tld 178.63.135.195 3 u 14 128 177 0.538 -0.448 1.638

0.de.pool.ntp.o .INIT. 16 u ... (more)

edit flag offensive delete link more

Comments

hi, I update my first answer.

mskalski ( 2015-10-20 11:01:27 -0700 )edit

Question Tools

Follow
1 follower

Stats

Asked: 2015-10-16 09:58:19 -0700

Seen: 955 times

Last updated: Oct 20 '15