Ask Your Question
0

Arno SR1 with ODL deploy failed

asked 2015-10-07 18:40:36 -0800

threesmaller gravatar image

Hi, When I deployed Arno sr1 with opendaylight plugins by fuel, it has error when installing openstack. Can anyone give me some information?

image description

edit retag flag offensive close merge delete

6 answers

Sort by » oldest newest most voted
0

answered 2015-10-19 06:50:37 -0800

Deivarayan gravatar image

updated 2015-10-19 08:49:16 -0800

@threesmaller: Could you please let me know whether you solved this problem. I have the same exact error. I tried twice.

My set up: Fuel - VM

Controller+Cinder and compute - bare metal

Controller - 500 GB, 8GB RAM

Compute - 700 GB, 32 GB RAM

I tried to increase the disk space of base storage in controller as well but it didnt work

edit flag offensive delete link more
0

answered 2015-11-07 01:25:55 -0800

wuwb1989 gravatar image

I think maybe your settings on nodes are wrong. You can check interfaces of all the nodes. As i know it should be like this:

    | interfaces   | useage                 |  
    |--------------|------------------------|
    | eht0         | Admin(PXE)             |
    | eht1         | Storage and Management | 
    | eht2         | Private                | 
    | eht3         | Public                 |
edit flag offensive delete link more
0

answered 2015-10-08 05:37:51 -0800

lmcdasm gravatar image

Hello.

Can you provide some more information about your deployment?

Namely the following: Size of deployment (number of controllers and computes) Are you using local mirrors or internet deployment? (Do your controller nodes have internet access?). Have you verified that your NTP server is available to all nodes?

its probably easier if you post the whole log in pastbin or something, since the information above doesnt provide too much info. from what i can see, you have tried several deployments (since you are up to NODE23), so it would be good to show your Settings Page (outlinging that you have enabled the ODL plugin correctly). as well as the networking and some information about your deployment.

Cheers,

edit flag offensive delete link more

Comments

My deployment is 3 nodes (1 controller, 2 compute), GRE and ODL plugin with VXLAN, using local mirrors ubuntu.

threesmaller ( 2015-10-08 19:14:24 -0800 )edit

Hey there. ok - can you confirm that all nodes have access to your valid NTP server (not the FUEL node)? Can you send me the Astute log (since you can see above the "RED" in your output that there is more info in the Astute log. Thanks

lmcdasm ( 2015-10-08 19:54:11 -0800 )edit

Hi, it would be also useful if you share with us /var/log/puppet.log file from node 23. Did you run network verification from Networks tab before deployment?

mskalski ( 2015-10-09 11:21:37 -0800 )edit

When I didn't choose ceph and it deployed successfully, and then I deployed with ceph again. It still didn't work. I attach error log link. https://drive.google.com/file/d/0B42X5flqttyGSENPWXRieVoySWs/view?usp=sharing

threesmaller ( 2015-10-09 21:11:13 -0800 )edit
0

answered 2015-10-10 03:08:48 -0800

mskalski gravatar image

In first case deployment failed during keystone deployment and now logs indicate that ceph cluster was no ready in the given time. Could you check as @lmcdasm suggested if you have connection to external NTP servers? You can go to controller and run:

ip netns exec vrouter ntpq -c lpeer

How much resources you assigned to nodes? This is virtual environment or bare metal? Ceph definitely consume more resource than cinder.

edit flag offensive delete link more
0

answered 2015-10-10 06:03:55 -0800

threesmaller gravatar image

Hi

bare metal, and it is my environment with ceph

image description

edit flag offensive delete link more
0

answered 2015-10-13 13:09:42 -0800

buamod gravatar image

updated 2015-10-13 23:17:24 -0800

Same here I will upload the picture tonight with a fresh deployment, it fails too ??!! But Again I did it with two things more: More Ram and Base storage for the controller node.

So the controller has now 2 GB of Ram and you have to give more storage to the base 500 GB .. I read somewhere OpenContrail plugin if its with the controller it should be at least with a 250, so check this picture ..

image description

image description

Don't try GRE unless your switches can take the GRE BTW my environment is Windows 8.1 with VirtualBox ..

edit flag offensive delete link more

Comments

Hi, I am Andy. I deply the environment but the odl is failed, I find you use virtualbox too, can you up load some picture about node configuration and virtual machine network configuration in my question page(need some help about… by anjiaqi1234567)? I will be glad to receive your reply, thank you

anjiaqi1234567 ( 2015-12-10 17:45:03 -0800 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
2 followers

Stats

Asked: 2015-10-07 18:40:36 -0800

Seen: 242 times

Last updated: Nov 07 '15