Ask Your Question
0

openstack fails at pacemaker install

asked 2018-04-09 07:52:57 -0700

dglad gravatar image

OPNFV – Danube 3.0 Fuel install error. I am getting this error during the openstack install process. I have installed OS using fuel many times before on previous Openstack releases, and never ran into this. It says pacemaker can’t install without corosync, but corosync does appear to be installed. Would anyone know why I’m seeing this error?

Tried this with a single controller and a dual one, same result. Node is simple KVM, standard OVS VLAN config, with cinder as storage.

This is the command the install script seems to be failing at:

root@node-10:~# /usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold -o APT::Get::AllowUnauthenticated=1 install pacemaker Reading package lists... Building dependency tree... Reading state information... Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: pacemaker : Depends: corosync (>= 2.3.0) but it is not going to be installed E: Unable to correct problems, you have held broken packages. root@node-10:~#

Coroysnc appears to be installed passed the required version.

||/ Name Version Architecture Description +++-=====================================-=======================-=======================-================================================================================ ii corosync 2.3.5-3ubuntu2.1 amd64 cluster engine daemon and utilities root@node-10:~#

Puppet log, which is basically the output of the failed command.

2018-04-06 14:42:07 ERR (/Stage[main]/Corosync/Package[pacemaker]/ensure) E: Unable to correct problems, you have held broken packages. 2018-04-06 14:42:07 ERR (/Stage[main]/Corosync/Package[pacemaker]/ensure) pacemaker : Depends: corosync (>= 2.3.0) but it is not going to be installed 2018-04-06 14:42:07 ERR (/Stage[main]/Corosync/Package[pacemaker]/ensure) The following packages have unmet dependencies: 2018-04-06 14:42:07 ERR (/Stage[main]/Corosync/Package[pacemaker]/ensure) 2018-04-06 14:42:07 ERR (/Stage[main]/Corosync/Package[pacemaker]/ensure) The following information may help to resolve the situation: 2018-04-06 14:42:07 ERR (/Stage[main]/Corosync/Package[pacemaker]/ensure) or been moved out of Incoming. 2018-04-06 14:42:07 ERR (/Stage[main]/Corosync/Package[pacemaker]/ensure) distribution that some required packages have not yet been created 2018-04-06 14:42:07 ERR (/Stage[main]/Corosync/Package[pacemaker]/ensure) requested an impossible situation or if you are using the unstable 2018-04-06 14:42:07 ERR (/Stage[main]/Corosync/Package[pacemaker]/ensure) Some packages could not be installed. This may mean that you have 2018-04-06 14:42:07 ERR (/Stage[main]/Corosync/Package[pacemaker]/ensure) Reading state information... 2018-04-06 14:42:07 ERR (/Stage[main]/Corosync/Package[pacemaker]/ensure) Building dependency tree... 2018-04-06 14:42:07 ERR (/Stage[main]/Corosync/Package[pacemaker]/ensure) change from purged to present failed: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold -o APT::Get::AllowUnauthenticated=1 install pacemaker' returned 100: Reading package lists...

edit retag flag offensive close merge delete

Comments

Hi, I am also facing same issue. could you please share how you have resolved it, if you have found any workaround? Thanks.

cksharpa ( 2018-05-07 02:34:22 -0700 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2018-06-24 19:40:08 -0700

I have the exact same issue.

192.168.0.1

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
1 follower

Stats

Asked: 2018-04-09 07:52:57 -0700

Seen: 54 times

Last updated: Jun 24