[Apex/Tripleo] Danube 2.0: undercloud install failure (os-odl_l3-fdio-noha)

asked 2017-05-29 13:27:38 -0700

dbalsige gravatar image

Hi there

I am trying to deploy os-odl_l3-fdio-noha on three baremetal nodes in our lab. I am following the install guide and I am using apex version opnfv-apex*-4.0-danube.2.0.noarch.rpm on plain CentOS I am using this openstack repo: https://repos.fedorapeople.org/repos/... .

Deploying the os-odl_l3-fdio-noha.yaml scenario fails with:

Logging undercloud configuration to undercloud:/home/stack/apex-undercloud-install.log
ERROR: openstack undercloud install has failed. Dumping Log:
...
https://trunk.rdoproject.org/centos7-newton/94/1e/941ec3f4d1860cbc43c007ebe1f8e9bf9d5c519a_4297a92f/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found
2017-05-29 19:27:24 - Error: Execution of '/bin/yum -d 0 -e 0 -y install openstack-mistral-engine' returned 1: Error downloading packages:
2017-05-29 19:27:24 -   openstack-mistral-engine-3.0.3-0.20170307090022.12527ab.el7.centos.noarch: [Errno 256] No more mirrors to try.
2017-05-29 19:27:24 - Error: /Stage[main]/Mistral::Engine/Package[mistral-engine]/ensure: change from absent to present failed: Execution of '/bin/yum -d 0 -e 0 -y install openstack-mistral-engine' returned 1: Error downloading packages:
2017-05-29 19:27:24 -   openstack-mistral-engine-3.0.3-0.20170307090022.12527ab.el7.centos.noarch: [Errno 256] No more mirrors to try.
2017-05-29 19:27:34 - Error: Execution of '/bin/yum -d 0 -e 0 -y install openstack-tripleo-validations' returned 1: Error downloading packages:
2017-05-29 19:27:34 -   openstack-tripleo-validations-5.1.2-0.20170307104738.ce16415.el7.centos.noarch: [Errno 256] No more mirrors to try.
2017-05-29 19:27:34 - Error: /Stage[main]/Tripleo::Profile::Base::Validations/Package[openstack-tripleo-validations]/ensure: change from absent to present failed: Execution of '/bin/yum -d 0 -e 0 -y install openstack-tripleo-validations' returned 1: Error downloading packages:
2017-05-29 19:27:34 -   openstack-tripleo-validations-5.1.2-0.20170307104738.ce16415.el7.centos.noarch: [Errno 256] No more mirrors to try.
2017-05-29 19:27:42 - Error: Execution of '/bin/yum -d 0 -e 0 -y install openstack-mistral-api' returned 1: Error downloading packages:
2017-05-29 19:27:42 -   openstack-mistral-api-3.0.3-0.20170307090022.12527ab.el7.centos.noarch: [Errno 256] No more mirrors to try.
2017-05-29 19:27:42 - Error: /Stage[main]/Mistral::Api/Package[mistral-api]/ensure: change from absent to present failed: Execution of '/bin/yum -d 0 -e 0 -y install openstack-mistral-api' returned 1: Error downloading packages:
2017-05-29 19:27:42 -   openstack-mistral-api-3.0.3-0.20170307090022.12527ab.el7.centos.noarch: [Errno 256] No more mirrors to try.
2017-05-29 19:28:20 - Error: Execution of '/bin/yum -d 0 -e 0 -y install openstack-mistral-executor' returned 1: Error downloading packages:
2017-05-29 19:28:20 -   openstack-mistral-executor-3.0.3-0.20170307090022.12527ab.el7.centos.noarch: [Errno 256] No more mirrors to try.
2017-05-29 19:28:20 - Error: /Stage[main]/Mistral::Executor/Package[mistral-executor]/ensure: change from absent to present failed: Execution of '/bin/yum -d 0 -e 0 -y install openstack-mistral-executor' returned 1: Error downloading packages:
2017-05-29 19:28:20 -   openstack-mistral-executor-3.0.3-0.20170307090022.12527ab.el7.centos.noarch: [Errno 256] No more mirrors to try.
...

When logged into undercloud VM, "yum update" fails indeed with:

https://trunk.rdoproject.org/centos7-newton/94/1e/941ec3f4d1860cbc43c007ebe1f8e9bf9d5c519a_4297a92f/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found
Trying other mirror.
To address this issue please ...
(more)
edit retag flag offensive close merge delete

Comments

I opened a ticket in Jira: https://jira.opnfv.org/browse/APEX-479

dbalsige ( 2017-06-22 08:12:47 -0700 )edit