Ask Your Question
0

error installing Openstack using Fuel

asked 2016-11-08 09:12:06 -0700

BabuKothandaraman gravatar image

Hi,

I have been trying to install OPNFV os-odl_l2-sfc-noha scenario using FUEL installer. I have one Fuel-master, one control node and 1 compute node. I followed installation guidelines from http://artifacts.opnfv.org/fuel/brahm...

However I added public IP for interfaces in compute and control nodes since otherwise the network connectivity check failed.

When I install Openstack, it failes on both nodes with a lot of error messages starting with. Connection timed out - connect(2) at /etc/puppet/modules/osnailyfacter/manifests/fuelpkgs/setuprepositories.pp:21 on node fuel.

I'm stuck here, please guide me.

edit retag flag offensive close merge delete

3 answers

Sort by » oldest newest most voted
0

answered 2017-06-03 21:08:06 -0700

qiaojiang gravatar image

updated 2017-06-03 21:13:56 -0700

Hi, I have got this failure ‘Task[cluster-vrouter/3] ’ too, because i changed the etc/hostname and etc/hosts when deploying. It passed when i changed back the hostname .Hoping this helps

edit flag offensive delete link more
0

answered 2016-11-09 06:10:53 -0700

mskalski gravatar image

updated 2016-11-09 06:13:13 -0700

Hi,

Lets clarify first which release are you using: Colorado (as in tag) or Brahmaputra to which documentation you referred? This task setup_repositories.pp will fail if can't reach repositories. So first of all it should be verified if you are able to connect external address (use dns name to check if resolving names is working) from failed node. In this case it probably failing because communication with external repositories is not possible through admin network, however in next phase of deployment this connectivity also needs to be possible through public network. Both of this cases can be verified through "Connectivity Check" in fuel web interface. I'm not sure what do you mean by "I added public IP for interfaces" - this should be done by fuel from ip address range which you defined in environment settings.

In case connection to external resources is forbidden in your local environment you can use local mirros from fuel master: http://artifacts.opnfv.org/fuel/brahm... - mirros addresses are different for different releases so please verify with appropriate documentation.

If you are using virtual machines and your admin network gateway is set to fuel master IP address please also ensure that on host machine where you run VMs you have these settings in /etc/sysctl.conf:

net.bridge.bridge-nf-call-ip6tables = 0
net.bridge.bridge-nf-call-iptables = 0
net.bridge.bridge-nf-call-arptables = 0

It will disable iptables rules on linux bridges used by VMs and is required for functional NAT through fuel master vm. You can check current value with cat /proc/sys/net/bridge/bridge-nf-call-iptables and if it set to 1 modify configuration as above and apply with sysctl -p

edit flag offensive delete link more

Comments

Hi, I have given some answers and asked a question as another answer since this comment had a word limit. Please let me know if you can help

BabuKothandaraman ( 2016-11-15 06:14:21 -0700 )edit
0

answered 2016-11-10 06:58:46 -0700

BabuKothandaraman gravatar image

Hi, Thanks for your help!! I'm using Colorado release. I removed the manual IP's I gave for for the public interfaces and set the configuration in /etc/sysctl.conf and verified Connectivity check and it worked. But now Openstack installation is failing with this following error message Deployment has failed. All nodes are finished. Failed tasks: Task[cluster-vrouter/3] Stopping the deployment process!. When I checked the logs, it last try's to execute (Scope(Class[Osnailyfacter::Clustervrouter::Clustervrouter])) MODULAR: clustervrouter/clustervrouter.pp and it fails there.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
1 follower

Stats

Asked: 2016-11-08 09:12:06 -0700

Seen: 840 times

Last updated: Jun 03