Ask Your Question
0

Fail to install glance in control node

asked 2016-09-09 01:07:57 -0800

hotsizle gravatar image

updated 2016-09-09 01:24:37 -0800

Hello, as title, I failed to deploy my opnfv environment while error shows up when installing glance.

I use Fuel Brahmaputra-3.0 and there are 3 nodes: 1 Fuel Master, 1 Control Node(with ONOS & ODL) and 1 Compute Node

At master node I have done following to create local mirror resource:

wget http://mirror.fuel-infra.org/docker/u... -O /tmp/ubuntu.trusty.tar.xz

docker load -i /tmp/ubuntu.trusty.tar.xz

fuel-createmirror

fuel-bootstrap build --activate

The process bar stuck at "Installing Openstack: 100%" and went fail. Following is the Astute log with ERR level:

[673] Task '{"priority"=>4600, "type"=>"puppet", "id"=>"glance", "parameters"=>{"puppetmodules"=>"/etc/puppet/modules", "puppetmanifest"=>"/etc/puppet/modules/osnailyfacter/modular/glance/glance.pp", "timeout"=>3600, "cwd"=>"/"}, "uids"=>["5"]}' failed on node 5

And there are also errors in puppet log:

2016-09-09 06:19:54 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) E: There are problems and -y was used without --force-yes 2016-09-09 06:19:54 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) After this operation, 133 MB of additional disk space will be used. 2016-09-09 06:19:54 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) Need to get 31.9 MB of archives. 2016-09-09 06:19:54 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) 0 upgraded, 99 newly installed, 1 downgraded, 0 to remove and 5 not upgraded. 2016-09-09 06:19:54 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) libxml2 2016-09-09 06:19:54 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) The following packages will be DOWNGRADED: 2016-09-09 06:19:54 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-swiftclient python-taskflow python-tk python-wsme python-xattr 2016-09-09 06:19:54 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-semantic-version python-simplegeneric python-support 2016-09-09 06:19:54 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-pygraphviz python-pymongo python-pymongo-ext python-scipy 2016-09-09 06:19:54 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-networkx python-numpy python-osprofiler python-psycopg2 2016-09-09 06:19:54 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-ipaddr python-kazoo python-matplotlib python-matplotlib-data 2016-09-09 06:19:54 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-glance-store python-gridfs python-gtk2 python-httplib2 python-imaging 2016-09-09 06:19:54 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-egenix-mxdatetime python-egenix-mxtools python-glade2 python-glance 2016-09-09 06:19:54 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-bson python-bson-ext python-cairo python-castellan 2016-09-09 06:19:54 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) libxpm4 libxrandr2 libxslt1-dev libxss1 libxt6 python-automaton python-boto 2016-09-09 06:19:54 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) libxcursor1 libxdamage1 libxfixes3 libxft2 libxinerama1 libxml2-dev libxmu6 2016-09-09 06:19:54 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) libumfpack5.6.2 libvpx1 libxaw7 libxcb-render0 libxcb-shm0 libxcomposite1 2016-09-09 06:19:54 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) libpixman-1-0 libpq5 libsm6 libtcl8.6 libthai-data libthai0 libtk8.6 2016-09-09 06:19:54 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) liblapack3 libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0 libpathplan4 2016-09-09 06:19:54 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure ... (more)

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-09-25 23:25:45 -0800

hotsizle gravatar image

This is due to incompatible dependency of libxml2-4.7. Problem is solved, please refer to https://bugs.launchpad.net/fuel/+bug/... .

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
1 follower

Stats

Asked: 2016-09-09 01:07:57 -0800

Seen: 35 times

Last updated: Sep 25 '16