Ask Your Question
0

Deploy stucked when installing openstack - Fuel Brahmaputra-3.0

asked 2016-09-02 04:20:22 -0800

hotsizle gravatar image

updated 2016-09-06 01:28:08 -0800

Hello someone please help me with this,

I'm deploying Brahmaputra-3.0 by fuel.

There are 2 nodes in the environment:1 Fuel master + 1 control node (mongo DB + ODL)

I create both nodes in VMware and use NAT in VMware as the PXE admin network: VMware default NAT gateway to the Internet: 10.20.0.2/24 Fuel master: 10.20.0.3/24 control node: 10.20.0.4/24

The Unbuntu-14.04 has been installed successfully in the control node. But now I got stuck in "Installing openstack" stage at 25% and went fail. (Deploying at 69%)

Astute log with err level:

2016-09-01 12:50:35 ERROR [438] Error running RPC method granulardeploy: Deployment failed on nodes 8, trace: ["/usr/share/gems/gems/astute-8.0.0/lib/astute/deploymentengine.rb:68:in block (3 levels) in deploy'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/deployment_engine.rb:51:ineachslice'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/deploymentengine.rb:51:in block (2 levels) in deploy'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/deployment_engine.rb:49:ineach'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/deploymentengine.rb:49:in block in deploy'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/deployment_engine.rb:45:ineach'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/deploymentengine.rb:45:in deploy'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/orchestrator.rb:216:indeploycluster'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/orchestrator.rb:52:in granular_deploy'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/dispatcher.rb:92:ingranulardeploy'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/server.rb:189:in dispatch_message'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/server.rb:146:inblock in dispatch'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/taskqueue.rb:64:in call'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/task_queue.rb:64:inblock in each'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/taskqueue.rb:56:in each'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/task_queue.rb:56:ineach'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/server.rb:144:in each_with_index'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/server.rb:144:indispatch'", "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/server.rb:123:in `block in performmainjob'"] 2016-09-01 12:50:35 ERROR [438] No more tasks will be executed on the node 8

Control node log with error level:

2016-09-02 09:20:28 ERR (/Stage[main]/Main/Pinghost[172.16.0.1]/ensure) change from down to up failed: Timeout waiting for host '172.16.0.1' status to become 'up' after 60 seconds! 2016-09-02 09:20:28 ERR /usr/bin/puppet:8:in <main>' 2016-09-02 09:20:28 ERR ... (more)

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-09-04 16:01:01 -0800

There should be at least three nodes: fuel master, controller and compute. I suggest that the controller and the compute node have at least two NICs (ethernet interface): one for fuel admin/pxe, and other for openstack networks.

You should have 172.16.0.1 public gateway address in your network environment and it should be able to connect internet.

You never forget "Verify Networks" before the installation.

edit flag offensive delete link more

Comments

thanks for the advice @erolozcan. I've solved this

hotsizle ( 2016-09-06 00:49:34 -0800 )edit

Should the 10.20.0.1 gateway address be able to connect to the internet?

JanonWang ( 2016-09-25 04:54:25 -0800 )edit

It's not necessarily. The 10.20.0.0/24 LAN is for PXE boot and fuel deployment only. And only Fuel Master Node will be able to access internet through 10.20.0.1. But still, I suggest you make it connect to the internet since you may want to upgrade the resource in your Fuel Master Nod.

hotsizle ( 2016-09-25 23:34:03 -0800 )edit
0

answered 2016-09-06 01:00:58 -0800

hotsizle gravatar image

updated 2016-09-06 02:20:59 -0800

I figure it out referencing @erolozcan 's advice:

There I establish 2 NAT networks in the VMware environment: 10.20.0.0/24 & 172.16.0.0/24

Note that the gateways to the Internet are 10.20.0.2 & 172.16.0.2 rather than 10.20.0.1 & 172.16.0.1.

Both control & compute node have their one ethernet interface binding to 10.20.0.0/24 network and the other binding to 172.16.0.0/24. 10.20.0.0/24 is for PXE admin while 172.16.0.0/24 is for openstack control network.

For anyone with the same scenario who runs into the same problem, remember

  1. NOT to check the vlan tagging for "Public Networks" and

  2. assign "Public Networks" to the 172.16.0.0/24 ethernet interface at "Configure interface"(of Nodes) stage before deploying.

edit flag offensive delete link more

Comments

Additionally, you may need a 172.16.0.0/24 environment with a dhcp server for nodes to get an ip before odl starts to install.

hotsizle ( 2016-09-09 00:11:31 -0800 )edit

if there is no dhcp server in 172.16.0.0/24, Is the static ip feasible?

JanonWang ( 2016-09-25 04:57:07 -0800 )edit

The static ip works too. Just set the ip in 172.16.0.0/24 LAN manually right after ubuntu is installed and node is reboot (and before openstack installation). Note to set the ip within PUBLIC ip range in your environment.

hotsizle ( 2016-09-25 23:40:05 -0800 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
1 follower

Stats

Asked: 2016-09-02 04:20:22 -0800

Seen: 161 times

Last updated: Sep 06 '16