Ask Your Question
0

vPing_ssh test case fails in functest

asked 2016-07-07 08:02:44 -0700

shabari gravatar image

We are using OPNFV B-release with Compass as installer. When I run ./runtests.sh –n –t vpingssh. I get following error:

2016-06-28 16:27:35,031 - vPingssh- DEBUG - Status: BUILD 2016-06-28 16:27:38,204 - vPingssh- DEBUG - Status: BUILD 2016-06-28 16:27:41,391 - vPingssh- DEBUG - Status: ACTIVE 2016-06-28 16:27:41,391 - vPingssh- INFO - Instance 'opnfv-vping-2' is ACTIVE. 2016-06-28 16:27:41,391 - vPing_ssh- INFO - Adding 'opnfv-vping-2' to security group 'vPing-sg' ...

2016-06-28 16:27:41,731 - vPing_ssh- INFO - Creating floating IP for VM 'opnfv-vping-2'...

2016-06-28 16:27:41,973 - vPing_ssh- INFO - Floating IP created: '10.1.10.104'

2016-06-28 16:27:41,973 - vPing_ssh- INFO - Associating floating ip: '10.1.10.104' to VM 'opnfv
-vping-2'

2016-06-28 16:27:42,656 - vPing_ssh- INFO - Trying to establish SSH connection to 10.1.10.104..
.

2016-06-28 16:27:44,659 - vPing_ssh- DEBUG - Waiting for 10.1.10.104...

2016-06-28 16:27:50,828 - vPing_ssh- DEBUG - Console-log 'opnfv-vping-2': Sending discover...

2016-06-28 16:27:52,830 - vPing_ssh- DEBUG - Waiting for 10.1.10.104...

2016-06-28 16:28:00,978 - vPing_ssh- DEBUG - Waiting for 10.1.10.104...

2016-06-28 16:28:09,136 - vPing_ssh- DEBUG - Waiting for 10.1.10.104...

2016-06-28 16:28:17,321 - vPing_ssh- DEBUG - Waiting for 10.1.10.104...

2016-06-28 16:28:25,472 - vPing_ssh- DEBUG - Waiting for 10.1.10.104...

2016-06-28 16:34:24,612 - vPing_ssh- DEBUG - Waiting for 10.1.10.104...

2016-06-28 16:34:30,762 - vPing_ssh- ERROR - Cannot establish connection to IP '10.1.10.104'. Aborting

=============================================================================================

opnfv-vping-2
192.168.130.4 Floating IPs: 10.1.10.104

opnfv-vping-1 192.168.130.3

I observed, In opnfv-vping-2 vm, no IP was assigned. I can’t ping opnfv-vping-2 IPs 192.168.130.4, 10.1.10.104. I tried giving it static IP. Even after that I was unable to ping the IP. However, all other VMs are working fine including opnfv-vping-1 VM.

Please, shed some light on this issue. Is it the issue of vping_ssh test case or functest?

Thanks,

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2016-07-15 07:17:50 -0700

shabari gravatar image

updated 2016-07-15 07:18:25 -0700

resolved the issue after forcing floating IP to be assigned to VM1 instead of VM2. Changes made in configuration file.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
1 follower

Stats

Asked: 2016-07-07 08:02:44 -0700

Seen: 119 times

Last updated: Jul 15 '16