Ask Your Question
0

setting number of huge pages when using OVSNFV

asked 2016-07-04 01:35:22 -0800

schmil gravatar image

Hi,

I need to increase the amount of hugepages but can't find where it is done when using OVSNFV. Supposed it was set in grub but it isn't there.

Samuel

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2016-07-05 03:11:23 -0800

srik1782 gravatar image

Hi, Normally hugepages can be set as shown below:

> echo 1200 > /proc/sys/vm/nr_hugepages

If you want to set the hugepages by default while booting, you need to configure that in the grub configuration:

Edit '/etc/default/grub' file as shown below:

GRUBCMDLINELINUXDEFAULT="defaulthugepagesz=1G hugepagesz=1G hugepages=16 iommu=pt intel_iommu=on"

> update-grub

reboot and check with "cat /proc/cmdline".

But, by the way, did your deployment successful with the ovsnfv plugin in? Which OPNFV installer you are using? Fuel or Apex? I am using Fuel installer and my deployment is failing the with ovsnfv plugin.

Regards, Srikanth.

edit flag offensive delete link more

Comments

I tried that but the configuration was reset by the configuration in the /etc/default/ovs-dpdk file Finally I found out that the amount can be set by using OVS_NUM_HUGEPAGES in the /etc/default/ovs-dpdk Note that the number given is per NUMA Samuel

schmil ( 2016-07-06 06:12:15 -0800 )edit

The following link describes the parameters that can be configured in /etc/default/ovs-dpdk https://github.com/openstack/networking-ovs-dpdk/blob/master/doc/source/usage.rst

schmil ( 2016-07-06 06:13:35 -0800 )edit
0

answered 2016-07-10 03:23:48 -0800

schmil gravatar image

The best way to set the number of hugepages is to set the value OVSNUMHUGEPAGES in /etc/default/ovs-dpdk Note that the number given is per NUMA, so if you have 2 NUMAs set OVSNUMHUGEPAGES=TOTALREQUIREDPAGES/2

If '1G' value is used hugepages should be allocated before starting ovs, i.e.: at kernel boot command line as following defaulthugepagesz=1G hugepagesz=1G hugepages=16 and the following parameters should be set in /etc/default/ovs-dpdk OVSALLOCATEHUGEPAGES=false OVSHUGEPAGEMOUNT_PAGESIZE=1G

Regards, Samuel

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

Follow
1 follower

Stats

Asked: 2016-07-04 01:35:22 -0800

Seen: 1,485 times

Last updated: Jul 10 '16